IBM AIX Kernel and AIX Hardware commands

This article discuss some of the core commands. The intent is to provide a list that you can use as a ready reference. While the behavior of these commands should be identical in all releases of AIX, they have been only tested under AIX V5.3.

AIX Kernel Commands

How would I know if I am running a 32-bit kernel or 64-bit kernel?
To display if the kernel is 32-bit enabled or 64-bit enabled, type:

bootinfo -K

How do I know if I am running a uniprocessor kernel or a multiprocessor kernel?
/unix is a symbolic link to the booted kernel. To find out what kernel mode is running, enter ls -l /unix and see what file /unix it links to. The following are the three possible outputs from the ls -l /unix command and their corresponding kernels: 

/unix -> /usr/lib/boot/unix_up   # 32 bit uniprocessor kernel 
/unix -> /usr/lib/boot/unix_mp   # 32 bit multiprocessor kernel
/unix -> /usr/lib/boot/unix_64   # 64 bit multiprocessor kernel       

Note: AIX 5L Version 5.3 does not support a uniprocessor kernel.

Also Read: Frequently used AIX Commands

How can I change from one kernel mode to another?
During the installation process, one of the kernels, appropriate for the AIX version and the hardware in operation, is enabled by default. Use the method from the previous question and assume that the 32-bit kernel is enabled. Also assume that you want to boot it up in the 64-bit kernel mode. This can be done by executing the following commands in sequence: 

ln -sf /usr/lib/boot/unix_64    /unix
ln -sf /usr/lib/boot/unix_64    /usr/lib/boot/unix

bosboot -ad  /dev/hdiskxx
shutdown -r

The /dev/hdiskxx directory is where the boot logical volume /dev/hd5 is located. To find out what xx is in hdiskxx, run the following command:
 lslv -m hd5
 

Note: In AIX V5.2, the 32-bit kernel is installed by default. In AIX V5.3, the 64-bit kernel is installed on 64-bit hardware and the 32-bit kernel is installed on 32-bit hardware by default.

AIX Hardware Commands


How do I know if my machine is capable of running AIX 5L Version 5.3?
AIX 5L Version 5.3 runs on all currently supported CHRP (Common Hardware Reference Platform)-based POWER™ hardware.

How do I know if my machine is CHRP-based?
Run the prtconf command. If it's a CHRP machine, the string chrp appears on the Model Architecture line.

How do I know if my System p machine (hardware) is 32-bit or 64-bit?
To display if the hardware is 32-bit or 64-bit, type:

bootinfo -y

How much real memory does my machine have?
To display real memory in kilobytes (KB), type one of the following:

bootinfo -r    

lsattr -El sys0 -a realmem 

Can my machine run the 64-bit kernel?
64-bit hardware is required to run the 64-bit kernel.
What are the values of attributes for devices in my system?
To list the current values of the attributes for the tape device, rmt0, type:

lsattr -l rmt0 -E

To list the default values of the attributes for the tape device, rmt0, type:

lsattr -l rmt0 -D

To list the possible values of the login attribute for the TTY device, tty0, type:

lsattr -l tty0 -a login -R

To display system level attributes, type:

lsattr -E -l sys0

How many processors does my system have?
To display the number of processors on your system, type:

lscfg | grep proc

How many hard disks does my system have and which ones are in use?
To display the number of hard disks on your system, type:

lspv

How do I list information about a specific physical volume?
To find details about hdisk1, for example, run the following command: 

lspv hdisk1  
   
How do I get a detailed configuration of my system?
Type the following:

lscfg

The following options provide specific information:

-pDisplays platform-specific device information. The flag is applicable to AIX V4.2.1 or later.
-vDisplays the VPD (Vital Product Database) found in the customized VPD object class.

For example, to display details about the tape drive, rmt0, type: 

lscfg -vl rmt0

You can obtain similar information by running the prtconf command.

How do I find out the chip type, system name, node name, model number, and so forth?
The uname command provides details about your system.
uname -pDisplays the chip type of the system. For example, PowerPC®.
uname -rDisplays the release number of the operating system.
uname -sDisplays the system name. For example, AIX.
uname -nDisplays the name of the node.
uname -aDisplays the system name, nodename, version, machine ID.
uname -MDisplays the system model name. For example, IBM, 9114-275.
uname -vDisplays the operating system version.
uname -mDisplays the machine ID number of the hardware running the system.
uname -uDisplays the system ID number.

0 Comment to "IBM AIX Kernel and AIX Hardware commands"

Post a Comment